Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 19, 2025 - 09:01 UTC
Scheduled
Blockdaemon will update Bitcoin Core Mainnet nodes to v29.0 on 05/19/25. We are updating our nodes due to a release from the Bitcoin Core foundation. This update applies to all Blockdaemon Bitcoin Core Mainnet nodes, there will be planned downtime of up to 30 minutes per node.
- The RPC testmempoolaccept response now includes a reject-details field in some cases.
- Duplicate blocks submitted with submitblock will now persist their block data even if it was previously pruned.
- getmininginfo now returns nBits and the current target in the target field.
- getblock and getblockheader now return the current target in the target field.
- the getblocktemplate RPC curtime (BIP22) and mintime (BIP23) fields now account for the timewarp fix proposed in BIP94 on all networks.
We have tested the release and do not anticipate any unexpected downtime other than mentioned above as a result of the update. If you have any questions or concerns please reach out to your Customer Support Manager.
Posted May 14, 2025 - 12:50 UTC
This scheduled maintenance affected: Chain Watch ($BTC - Bitcoin), Blockdaemon RPC API (Bitcoin Native API), and Protocols (Dedicated Nodes) (Bitcoin).