Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 09:01 UTC
Scheduled
Blockdaemon will update all Ethereum mainnet RPC nodes to the Fusaka-compatible versions on November 25th, 2025 at 09:00 UTC. The following client versions will be deployed:
Customer Impact During the upgrade window, Ethereum RPC/API based services hosted by Blockdaemon may be temporarily unavailable for up to ten minutes while nodes are restarted and updated. Customers may experience temporary errors, failed or delayed transaction submissions, and intermittent issues when querying Polygon network data until the upgrade is complete.
Additional Information Blockdaemon has validated this release and does not anticipate unexpected disruptions beyond any stated downtime.
If you have any questions, please reach out to your Customer Success Manager.
Posted Nov 21, 2025 - 19:16 UTC
This scheduled maintenance affected: Blockdaemon RPC API (Ethereum Native API) and Protocols (Dedicated Nodes) (Ethereum).