Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 08:00 UTC
Scheduled
Core DAO will undergo the Hermes hard fork scheduled for November 25, 2025, at 08:00 UTC. This network-wide fork is part of the official Core DAO release.
Summary of Technical Changes • Activated Hermes hard fork on Mainnet at 2025-11-25 08:00:00 UTC. • Merged Binance Smart Chain updates up to v1.5.12. • Introduced fast finality: blocks now finalize in ~6 seconds. • Added validator enhancements including maintenance mode and improved block production. • Enabled support for BLS12-381 cryptography and new dApp functionality. • Added “staking channel” commission support for CORE and BTC staking.
Customer Impact No downtime is expected during this event.
Additional Information Blockdaemon has validated this release and does not anticipate any service disruption. Operators should ensure configuration files are updated per the new config.toml requirements. Release notes: https://github.com/coredao-org/core-chain/releases/tag/v1.0.22 If you have any questions, please reach out to your Customer Success Manager.
Posted Nov 11, 2025 - 16:48 UTC
This scheduled maintenance affected: Blockdaemon Validators (Core Validator).