*Urgent* [Polkadot] - Kusama and Westend Upgrade to v20.9.0

Incident Report for Blockdaemon

Resolved

This maintenance has been completed.
Posted Oct 07, 2025 - 11:45 UTC

Identified

Blockdaemon would like to inform customers that we will be performing an emergency upgrade to Sidecar API to v20.9.0 for Polkadot, Kusama, and Westend.

If you have any concerns or questions, please reach out to your customer success manager.

For further information on the release, please see the release notes here:
https://github.com/paritytech/substrate-api-sidecar/releases/tag/v20.9.0
Posted Oct 07, 2025 - 08:29 UTC
This incident affected: Chain Watch ($DOT - Polkadot), Staking Reporting API (Polkadot Staking Reporting), Staking API (Polkadot Staking API), Blockdaemon RPC API (Polkadot Native API), Blockdaemon Validators (Polkadot Validator), and Protocols (Dedicated Nodes) (Polkadot).