[Canton] Mainnet Upgrade to Splice v0.6.4

Scheduled for Jun 4, 14:00 - 15:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 01, 2026 - 14:22 UTC

Scheduled

Blockdaemon will update all Canton Mainnet nodes to Splice v0.6.4 and Wallet Gateway to v1.4.0 on 06/04/2026 at 14:00 UTC. We are updating our nodes due to a release from the Canton foundation. This update applies to all Canton Mainnet nodes; there will be planned downtime of up to 15 minutes per node.

We have tested the release and do not anticipate any unexpected downtime other than mentioned above as a result of the update. If you have any questions or concerns, please reach out to your Customer Success Manager.

If you want additional information, please review the release notes here:
https://docs.canton.network/global-synchronizer/release-notes/splice
https://github.com/canton-network/wallet/releases/tag/%40canton-network%2Fwallet-gateway-remote%401.4.0
Posted Jun 01, 2026 - 11:30 UTC
This scheduled maintenance affects: Blockdaemon Validators (Canton Validator).