[Solana Mainnet Nodes Issue]
Incident Report for Blockdaemon
Resolved
We are pleased to inform you that the previously reported issue with Solana mainnet nodes falling behind the blockchain has been resolved. Following our emergency upgrade of the RPC nodes from v1.18.26 to v2.0.15, we have observed stable performance across all Solana nodes.

Our engineering team will continue to monitor the situation closely, but at this time, all affected services are operating normally.

We appreciate your patience and understanding throughout this incident. If you have any questions or need further assistance, please don't hesitate to reach out to your Customer Success Manager.

Thank you for your cooperation!
Posted Nov 10, 2024 - 21:40 UTC
Update
Blockdaemon would like to make customers aware that as part of our effort to mitigate the issue, we will be upgrading all Solana RPC nodes to v2.0.15 (includes v2.0.14) today.

Please note there are a number of RPC calls deprecated in this release, the full list and their replacements can be found here; https://github.com/anza-xyz/agave/wiki/Agave-v2.0-Transition-Guide

If you have any questions or concerns please reach out to your Customer Success Manager.
If you want additional information please review the release notes here;
https://github.com/anza-xyz/agave/releases/tag/v2.0.15
https://github.com/anza-xyz/agave/releases/tag/v2.0.14
Posted Nov 10, 2024 - 10:06 UTC
Investigating
We are experiencing an issue with Solana mainnet nodes falling behind the blockchain. Our initial assessment suggests this may be related to a network issue, but our engineering team is actively investigating to identify the root cause and implement a solution.

As a result, clients using Ubiquity for Solana may also experience issues with Solana mainnet methods, as these are directly affected by the current node performance.

We appreciate your patience and understanding as we work to resolve this. We will provide updates as more information becomes available.

If you have any questions, please feel free to reach out to your Customer Success Manager.

Thank you!
Posted Nov 09, 2024 - 23:26 UTC
This incident affected: Blockdaemon RPC API (Solana Native API) and Protocols (Dedicated Nodes) (Solana).