[Polkadot] - v1.14.0 upgrade performance issues
Incident Report for Blockdaemon
Resolved
Blockdaemon would like to inform customers that due to observing no issues post downgrade to Polkadot v1.13.0, we are resolving this incident. Once the patch has been released from the Parity foundation, we will endeavour to roll out Polkadot v1.14 or the latest version again. Any further protocol updates will proceed as per our normal process.
Posted Jul 17, 2024 - 09:09 UTC
Monitoring
The rollback to Polkadot v1.13.0 across all Blockdaemon Westend, Kusama and Polkadot RPC nodes has been completed successfully. We will now monitor the nodes for a period of time to ensure the issue has not persisted.
If you have any concerns or questions, please reach out to your customer success manager.
Posted Jul 16, 2024 - 13:07 UTC
Update
Blockdaemon would like to inform customers that we will be rolling back the Polkadot v1.14.0 release to v1.13.0. We will only be rolling back Westend, Kusama and Polkadot RPC nodes. The rollback will commence at 12:00 UTC today.
We expect up to 10 minutes of downtime per node.
If you have any concerns or questions, please reach out to your customer success manager.
For further information on the release, please see the release notes here; https://github.com/paritytech/polkadot-sdk/releases/tag/polkadot-v1.13.0
Posted Jul 16, 2024 - 08:59 UTC
Identified
Blockdaemon would like to inform customers that we have identified a bug with the latest release of Polkadot, v1.14.0, which we upgraded to this morning. The bug can cause nodes to intermittently become unresponsive for a short period of time. The bug has been fixed in the upstream dependency and we are in touch with the Parity foundation regarding both a temporary and permanent resolution.
Posted Jul 15, 2024 - 15:32 UTC
This incident affected: Blockdaemon Universal API, Staking Reporting API (Polkadot Staking Reporting), Staking API (Polkadot Staking API), Blockdaemon RPC API (Kusama Native API, Polkadot Native API), Public Validators (Kusama Validator, Polkadot Validator), and Protocols (Dedicated Nodes) (Kusama, Polkadot).