We are pleased to inform you that the issue affecting network stall on the SUI Mainnet has been resolved, and the service is now fully operational.
We sincerely apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the matter.
If you have any further questions or concerns, please don’t hesitate to reach out to your Customer Success Manager!
Thank you for your understanding!
Posted Jan 15, 2026 - 01:57 UTC
Update
Blockdaemon is aware of a network stall on the SUI Mainnet. As per the recommendation of the SUI Foundation, we are temporarily halting our validator operations as a precautionary measure.
Walrus and Ika are also currently disrupted as a result of this stall. These protocols rely on the SUI network for coordination and settlement.
We are closely monitoring the situation across all affected services and will provide further updates as soon as more information becomes available.
If you have any questions, please reach out to your Customer Success Manager.
Posted Jan 14, 2026 - 23:23 UTC
Investigating
Blockdaemon is aware of a network stall on the SUI Mainnet. Per the recommendation of the SUI Foundation, we are temporarily halting our validator operations as a precautionary measure.
We are closely monitoring the situation and will provide further updates as soon as more information becomes available.
If you have any questions, please reach out to your Customer Success Manager.
Posted Jan 14, 2026 - 16:12 UTC
This incident affected: Blockdaemon Validators (Ika Validator, SUI Validator) and Protocols (Dedicated Nodes) (SUI).