Web application issue

Incident Report for Blockdaemon

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 17:16 UTC

Update

We are continuing to investigate this issue.
Posted Oct 09, 2025 - 09:24 UTC

Investigating

We want to inform you that we are currently experiencing an issue with our web application product. Due to this issue, clients are unable to add dedicated RPC nodes to their portfolio.

Our engineering team is actively investigating the issue and apologise for any inconvenience this may cause.

We will keep you posted with any updates on the resolution progress. If you have any questions, please contact your customer success manager or reach out to support@blockdaemon.com

Thank you for your understanding!
Posted Oct 09, 2025 - 09:23 UTC
This incident affected: Blockdaemon Web App.