Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 18:00 UTC
Update
Blockdaemon is extending the current maintenance window impacting the Ethereum Staking API and Ethereum validator infrastructure. This extension is necessary to complete ongoing maintenance tasks safely and ensure optimal performance across affected systems.
Impact During this window, staking intent submissions and related API calls for Ethereum may be temporarily unavailable or experience degraded performance. Other services remain unaffected.
Posted Oct 23, 2025 - 17:50 UTC
Scheduled
We will be performing maintenance which will impact the Ethereum Staking API and Ethereum validator infrastructure. During this window, staking intent submissions and related API calls for Ethereum may be temporarily unavailable or experience degraded performance.
If you have any questions or concerns please reach out to your Customer Success Manager.
Posted Oct 22, 2025 - 11:11 UTC
This scheduled maintenance affected: Staking API (Ethereum Staking API) and Blockdaemon Validators (Ethereum Validators).