Kusama nodes experiencing slow finalisation
Incident Report for Blockdaemon
Resolved
We are pleased to inform you that the issue affecting Kusama nodes has been resolved, and the service is now fully operational.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the matter.

If you have any further questions or concerns, please don’t hesitate to reach out to your Customer Success Manager!

Thank you for your understanding!
Posted Nov 26, 2024 - 07:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2024 - 20:32 UTC
Investigating
The Kusama network is currently experiencing widespread slow finalisation. This issue may impact the performance of Kusama nodes, potentially causing delays in transaction confirmations and affecting dependent services.
Posted Nov 25, 2024 - 16:31 UTC
This incident affected: Blockdaemon RPC API (Kusama Native API), Public Validators (Kusama Validator), and Protocols (Dedicated Nodes) (Kusama).