Unable to launch new nodes via Web App
Incident Report for Blockdaemon
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 10:05 UTC
Investigating
We regret to inform you that we are experiencing an ongoing issue, currently affecting the launch of new dedicated nodes via the Blockdaemon Web App. Please note that all existing nodes are currently operational and we are working diligently to resolve this issue as quickly as possible. We will continue to provide updates as more information becomes available.

We apologize for any inconvenience caused and thank you for your patience as we work to resolve this matter.
Posted Apr 25, 2024 - 17:53 UTC
This incident affected: Blockdaemon Web App.