Blockdaemon is extending the Polygon maintenance window to include the Bor v2.3.3 release. The Bor update was released as a critical security patch, and we are applying both the Heimdall v0.4.2 and Bor v2.3.3 upgrades during the same window. There will be planned downtime of up to 10 minutes while nodes restart and apply both updates.
Posted Oct 15, 2025 - 16:44 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 15, 2025 - 15:00 UTC
Scheduled
Blockdaemon will update all Polygon nodes to Heimdall v0.4.2 on October 15, 2025 at 10:00 UTC. We are updating our nodes due to the official release for Polygon. There will be planned downtime of up to 10 minutes.
Customer Impact During the maintenance window, Polygon services hosted by Blockdaemon may be briefly unavailable while nodes restart and apply the update. Normal operation will resume once the upgrade is complete.
Additional Information Blockdaemon has validated this release and does not anticipate unexpected disruptions beyond any stated downtime. Release notes: https://github.com/0xPolygon/heimdall-v2/releases/tag/v0.4.2 If you have any questions, please reach out to your Customer Success Manager.
Posted Oct 14, 2025 - 18:41 UTC
This scheduled maintenance affected: Staking Reporting API (Polygon Staking Reporting), Staking API (Polygon Staking API), Blockdaemon RPC API (Polygon Native API), Blockdaemon Validators (Polygon Validator), and Protocols (Dedicated Nodes) (Polygon).