[Kusama] – Sidecar Staking Endpoint Error

Incident Report for Blockdaemon

Resolved

The issue has been resolved following an upgrade to Substrate API Sidecar v20.13.3. All affected services are operating normally.

If you have any questions or experience any additional issues, please contact your Customer Success Manager.
Posted Jan 06, 2026 - 17:50 UTC

Identified

Blockdaemon will perform an urgent update to the Substrate API Sidecar service, upgrading to v20.13.3, which includes fixes released by the Parity team. This update will be rolled out to all affected Kusama full nodes.

During the update, customers may experience brief service interruptions on their nodes. This downtime is required to apply the fix and restore normal service operation.

We have validated this release and expect the upgrade to fully resolve the incident without any additional impact beyond the brief interruptions noted above.

Further updates will be posted here as the rollout progresses. If you have any questions or concerns, please contact your Customer Success Manager.

Additional information:
https://github.com/paritytech/substrate-api-sidecar/releases/tag/v20.13.3
Posted Jan 06, 2026 - 16:48 UTC

Investigating

We are investigating an issue affecting the Kusama AssetHub Sidecar service.

The issue has been identified and is related to an upstream dependency. We are coordinating with Parity to address the problem.

The issue will remain until an update is released and deployed. We will provide further updates as more information becomes available.

If you have any questions or need further assistance, please don't hesitate to contact your Customer Success Manager!
Posted Jan 05, 2026 - 13:34 UTC
This incident affected: Blockdaemon RPC API (Kusama Native API) and Protocols (Dedicated Nodes) (Kusama).