[Cosmos] - Cosmos Network Down

Incident Report for Blockdaemon

Resolved

We are pleased to inform you that the issue affecting Cosmos Network has been resolved, and the service is now fully operational.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the matter.

If you have any further questions or concerns, please don’t hesitate to reach out to your Customer Success Manager.
Posted Apr 14, 2025 - 19:10 UTC

Investigating

Blockdaemon would like to make customers aware that the Cosmos Network is currently facing an outage. All nodes on the Cosmos network are currently impacted. The foundation are working on a resolution and we have engineers ready to execute any necessary actions.

We will keep you informed and share updates as progress is made. We sincerely apologize for any inconvenience this may be causing and appreciate your patience as we work to resolve the matter.

If you have any questions or need further assistance, please don't hesitate to contact your Customer Success Manager.
Posted Apr 14, 2025 - 15:33 UTC
This incident affected: Staking API (Cosmos Staking API), Public Validators (Cosmos Validator), Blockdaemon RPC API (Cosmos Native API), and Protocols (Dedicated Nodes) (Cosmos).