[Stellar] - Testnet Horizon Nodes Out of Sync

Incident Report for Blockdaemon

Resolved

We are pleased to inform you that the issue affecting Stellar Testnet Horizon nodes has been resolved, and the service is now fully operational.

If you have any further questions or concerns, please don’t hesitate to reach out to your Customer Success Manager!
Posted Feb 05, 2026 - 16:07 UTC

Investigating

We want to inform you that we are currently experiencing issues with our Stellar Horizon Testnet nodes. Our team is actively investigating the problem and working diligently to resolve it. As a result, you may experience synchronization issues with Stellar Testnet Horizon nodes.

We apologize for any inconvenience this may cause and appreciate your patience and understanding. We will keep you updated on any developments!

If you have any questions or concerns, please reach out to your Customer Success Manager.
Posted Feb 05, 2026 - 12:58 UTC
This incident affected: Blockdaemon RPC API (Stellar Native API) and Protocols (Dedicated Nodes) (Stellar).