Blockdaemon have updated to the emergency patch released by Mysten Labs on both Testnet and Mainnet. We will monitor the network and will resolve if no further issues arise.
Posted Nov 21, 2024 - 15:24 UTC
Investigating
We have identified that the SUI network is currently experiencing health issues, impacting users across the network. Mysten Labs, the maintainers of the SUI network, are actively investigating the root cause.
Our team is closely monitoring the situation and remains in constant communication with Mysten Labs for updates. Should a hotfix or any mitigation steps be required, we are prepared to act promptly to minimize disruption.
Thank you for your patience and understanding as we work with Mysten Labs to resolve this issue. We will provide further updates as more information becomes available.
Posted Nov 21, 2024 - 10:43 UTC
This incident affected: Protocols (Dedicated Nodes) (SUI).