AMS Network Connectivity Issues

Incident Report for Blockdaemon

Monitoring

A fix has been implemented for the issue affecting nodes in the Amsterdam (AMS) region, and we are currently monitoring the service to ensure stability.

We will provide further updates once the monitoring period is complete and the issue is fully resolved. We sincerely apologize for any inconvenience this may have caused and appreciate your patience.

If you have any questions or need assistance, please reach out to your Customer Success Manager.
Posted Mar 27, 2026 - 00:25 UTC

Investigating

We are investigating an upstream network provider issue impacting nodes in the Amsterdam (AMS) region, which may result in connectivity issues.

We are actively monitoring the situation and will provide updates as more information becomes available.

If you have any questions or concerns, please reach out to your Customer Success Manager.
Posted Mar 26, 2026 - 23:09 UTC
This incident affects: Protocols (Dedicated Nodes) (Algorand, Aptos, Arbitrum, Arc, Avalanche, Babylon, Base, Bitcoin, BNB, Cardano, Cosmos, Cronos, Dogecoin, Ethereum, Kusama, Near, Optimism, Polkadot, Provenance, Skale, Solana, Stellar, Tron), Blockdaemon RPC API (Algorand Native API, Aptos Native API, Arbitrum Native API, Arc Native API, Avalanche Native API, Base Native API, Bitcoin Native API, Cronos Native API, Dogecoin Native API, Ethereum Native API, Monad Native API, Near Native API, Optimism Native API, Polkadot Native API, Polygon Native API, Solana Native API, Stellar Native API), Blockdaemon Universal API, and Blockdaemon Validators (Avalanche Validator, Ethereum Validators, Polygon Validator, Provenance Validator, Solana Validator, TON Validator).