Account Balance Issues for BCH and LTC

Incident Report for Blockdaemon

Resolved

This incident has been resolved.
Posted Nov 13, 2022 - 20:41 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 13, 2022 - 19:43 UTC

Investigating

We are currently investigating issues retrieving balances for Bitcoin Cash and Litecoin
Posted Nov 13, 2022 - 19:12 UTC
This incident affected: Blockdaemon Universal API.