Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 28, 2025 - 22:45 UTC
Scheduled
Blockdaemon will update all NEAR Protocol nodes to 2.9.0 on October 28, 2025 at 11:45 UTC. We are updating our nodes due to the official release for NEAR Protocol. There may be planned downtime of up to 10 minutes.
Summary of Technical Changes • Reduces NEAR’s maximum inflation parameter from 5% to 2.5%.  • Upgrades protocol version from 80 to 81.  • Introduces governance voting to activate protocol v81 (scheduled to begin Oct 28, 2025 01:00 UTC).  • Specifies activation occurs after stake-voting threshold is met; no network fork expected for this change. 
Customer Impact During the maintenance window, NEAR endpoints hosted by Blockdaemon may be briefly unavailable while nodes restart. Requests may fail or time out during the planned downtime of up to 10 minutes; service will resume automatically once the upgrade completes.
Additional Information Blockdaemon has validated this release and does not anticipate unexpected disruptions beyond any stated downtime. Release notes: https://github.com/near/nearcore/releases/tag/2.9.0 If you have any questions, please reach out to your Customer Success Manager.
Posted Oct 28, 2025 - 22:39 UTC
This scheduled maintenance affected: Staking API (Near Staking API), Blockdaemon RPC API (Near Native API), Blockdaemon Validators (Near Validator), and Protocols (Dedicated Nodes) (Near).