Degraded Performance - Avalanche Mainnet Native

Incident Report for Blockdaemon

Resolved

This incident has been resolved.
Posted Sep 23, 2026 - 09:41 UTC

Identified

We are currently investigating an issue affecting Avalanche Mainnet Native RPC, Archive, and Validator services. As a result, some requests to these endpoints may return errors or fail intermittently.

A fix has been identified and is being rolled out. We will also be carrying out a brief maintenance window to complete this rollout across the nodes.

We apologize for any inconvenience this may cause and appreciate your patience and understanding. We will provide updates as more information becomes available.

If you have any questions or concerns, please reach out to your Customer Success Manager.
Posted Sep 23, 2026 - 05:16 UTC
This incident affected: Blockdaemon Validator (Avalanche Validator), Blockdaemon RPC API (Avalanche Native API), and Protocols (Dedicated Nodes) (Avalanche).