[GCP] - Multiple Services outage

Incident Report for Blockdaemon

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:53 UTC

Monitoring

We’re seeing widespread issues with Cloud and Routing Providers, which are intermittently affecting connectivity to our services.
We’re actively monitoring the situation and will provide updates as soon as we have more information.
Posted Jun 12, 2025 - 21:21 UTC
This incident affected: Blockdaemon Web App and Blockdaemon Universal API.