Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 06, 2025 - 18:00 UTC
Scheduled
Blockdaemon will update all dYdX nodes to protocol v9.4.0 on November 6, 2025 18:00 UTC. We are updating our nodes due to the official release for dYdX. There will be planned downtime of up to 10 minutes.
Summary of Technical Changes • Introduces “fee-free holidays” for certain markets.  • Implements sliding affiliate fee tiers based on 30-day referred volume, with caps and commission/override integration.  • Adds dynamic, per-market leverage and enforces leverage checks on order placement and on withdrawals/updates.  • Adds staking-based fee discounts and considers staking tiers in fee calculations.  • Fixes TWAP maker suborders not correctly updating TWAP state. 
Customer Impact During the planned maintenance window, customers may experience a brief interruption in service (up to 10 minutes). RPC/API requests to affected nodes may fail or time out, and sessions may need to reconnect once nodes return to service. No action is required from customers after completion.
Additional Information Blockdaemon has validated this release and does not anticipate unexpected disruptions beyond any stated downtime. Release notes: https://github.com/dydxprotocol/v4-chain/releases/tag/protocol%2Fv9.4.0 If you have any questions or concerns, please reach out to your Customer Success Manager.
Posted Nov 05, 2025 - 06:57 UTC
This scheduled maintenance affected: Blockdaemon Validators (dYdX Validator) and Protocols (Dedicated Nodes) (dYdX).